Issue with Embedded SSO (iframe integration) not automatically logging users in, for some URLs
Incident Report for Streem
Postmortem

On Wednesday March 2nd, 2022 Streem experienced a limited outage for users combining Streem Embedded SSO with the Streem iFrame integration. In normal use, These users would authenticate into the service with no Password, but in this case, users were presented with a login page. This was a Major outage for these users as there was no alternative to login by the nature of Embedded SSO.

Root Cause:
The issue was caused at the time of a normal scheduled weekly code release and was identified 15 minutes after release by Streem internal tool tests. While post release tests worked as designed, alerts and tests prior to release did not catch the behavior change.

Mitigation:
Streem will move redundant testing further up the release process in order to validate this impact is avoided in the future. Streem will review failed portion of the testing process to identify and resolve flaws.

Posted Mar 04, 2022 - 18:25 UTC

Resolved
For Embedded SSO integrations that utilized our short-form URL, company.streempro.app, users were not automatically logged in, and instead shown a Login form. Our internal monitoring detected this issue immediately, and a fix was released at about 7:50pm PT.
Posted Mar 02, 2022 - 23:30 UTC