Streem Call Invitations Not Working For Customers Using Embedded Workspaces
Incident Report for Streem
Resolved
This incident has been resolved an invitations are working as expected for all customers.
Posted Jun 03, 2022 - 20:36 UTC
Monitoring
A fix for this issue has been implemented and we're seeing successful invitations for our customers using the embedded version of Streem. We are continuing to monitor the status to ensure recovery is sustained.
Posted Jun 03, 2022 - 20:14 UTC
Investigating
We are currently investigating an issue preventing experts from inviting customers to a Streem Call (both SMS and link invitations) when the expert is using the embedded version of Streem. If you use Streem in your regular web browser, this should not affect you.

We'll update this post when we have additional information.
Posted Jun 03, 2022 - 17:16 UTC
This incident affected: SMS Invitations.